Limit orders won't go through

Try to get limit orders to go through.
Can’t get them to work either through the UI or the API. Not sure what the problem is.
UI
Followed the instructions, selected the tokens, connected a wallet, authorized the transaction, wait for it to clear, confirmed on etherscan, noted that the ‘lock’ icon was gone, placed a small limit order (for much less than available funds). After I place the order, it shows up in the current orders panel with a yellow border. It has this error/warning: “This order won’t be executed. USDT token is not approved”. Is there something else that I’m supposed to do to approve it?
Update on UI. For some reason, when I connected a different ETH wallet that should have been identical, and did all of the same things, it worked, and I was able to successfully post limit order through the UI. Still not through the API, see below.

API
I also tried to place limit orders through the api, the real objective. followed the (not very clear) instructions and code examples as closely as possible. Tried many different ways. Looked at a number of example repos. Used and double checked public/private key, token addresses, amounts, etc. All I can get back from the server is:
statusCode: 400,
message: ‘order is invalid with reason: unknown’,
error: ‘Bad Request’

Help greatly appreciated.

Thank you