General swap question

I used 1inch for the first time to swap eth to an ALT token. Linked MetaMask and made the swap. But I can’t see the tokens in metamask. I have added the custom address. Not sure what is missing and there isn’t anywhere else I can ask for help.

Hi niku, just wondering, are you sure you used the correct Custom Token Contract Address. I like to go to CoinGecko and search the altcoin then copy the MetaMask Contract address. If you did this and you are out of option, have you tried contacting MetaMask support for help?

Thanks I am asking them now.

1 Like

Have you actually added the token to MetaMask? After entering everything to receive, your last step is to click on add token, search for it, then click add. Is your alt token you swapped showing in MetaMask with 0 balance or not showing at all? If it’s not showing at all then you need to add it and you should be good. Hope this helps.

I have solved the problem now. The browser extension needed to be set to read data from all sites.

1 Like

Can you explain how you did that? I seem to be having the same problem.